WSUS Not working on Windows Server 2025

When setting up WSUS on a Windows Server 2025, one might encounter issues with the update of the repository, and the server will never synchronise.

After looking at the logs, which can be found in the C:\Windows\UpdateLog.log one would see timeout errors.

First things to check are the firewall and internet access of the server. The other reason why the synchronization would fail it would be due to the security defaults of Windows Server 2025, where TLS and SSL, which are disabled by default.

For WSUS to work, one needs to enable these protocols. To enable them, one can use applications such as IIS Crypto, which can be downloaded from the link below.

https://www.nartac.com/Products/IISCrypto/

After enabling TLS and SSL, reboot the server. After logging in, try to synchronize the WSUS, and it should be working.

Comments

Leave a Reply

Your email address will not be published. Required fields are marked *