Fix: Exchange 2010 error when trying to log into OWA or ECP using Administrator only

After a fresh new installation in an already existent domain setup, when I tried to access the OWA (Outlook Web Access) or ECP (Exchange Control Panel) using the Domain\Administrator only (in my case). I got the below error:

A problem occurred while trying to use your mailbox. Please contact technical support for your organization.

When you click on More Details on the page, you will get:

Request
Url: https://mail.mydomain.local:443/owa/lang.owa
User host address: 10.1.1.1
User: User's Name
EX Address: /o=DOMAIN/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=administrator
SMTP Address: administrator@mydomain.local
OWA version: 14.0.694.0
Exception
Exception type: Microsoft.Exchange.Data.Storage.StoragePermanentException
Exception message: There was a problem accessing Active Directory. Check your network connections and try again.

Well, before you start tearing you hair, there is a simple fix for this. The problem is just security and can be fixed by the following steps.

Open Active Directory Users and Computers
Click on View and select Advanced Features
Find the user, right click and select Properties
Click on the Security tab and click on the Advanced button
Make sure that the Include Inheritibale Permissions checkbox is ticked

Open a new browser window and try to log in again. Swing! it lives! Thou in my case the issue was with just the administrator, it can be applicable to all the users.

(2366)