Fix: Lync 2010 error while checking prerequisite Wmf2008R2, failure code 3

You might get this error when installing Lync 2010 server on a server running Windows Server 2008 R2 SP1. This error happens because the installer has not been updated to work with this version of Windows. As a work around, enable the Windows Desktop Experience pack using server manager, reboot and try the installation again.

(558)